Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska
Duo Under Investigation
Incident Report for IT
Resolved
All systems are operating normally. This issue is resolved.
Posted Jun 14, 2019 - 09:38 CDT
Monitoring
All issues appear to have subsided, and all systems are performing as expected. We're continuing to monitor for any reoccurring problems.
Submitted by Kristy Kennedy
Posted Jun 13, 2019 - 12:45 CDT
Investigating
Potential problem with Duo is under investigation. Technicians are investigating the issue.
Reported by Kristy Kennedy
Submitted by Kristy Kennedy
Questions 402-472-3970 or mysupport@nebraska.edu
Posted Jun 13, 2019 - 12:37 CDT
This incident affected: Information Security (Two-Factor Authentication).