Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska
Lincoln Telephone service under investigation
Incident Report for IT
Resolved
All systems are operating normally. This issue is resolved.
Updated by Kylie Longwell
Posted Oct 22, 2020 - 11:13 CDT
Investigating
Potential problem with Telephone service in Lincoln is under investigation. Currently outside callers trying to call into a UNL phone number are experiencing a fast busy signal. Windstream is investigating this issue.
Reported by Tammy Craig
Submitted by Loren Frerichs
Questions 402-472-3970 or support@nebraska.edu
Posted Oct 22, 2020 - 09:30 CDT
This incident affected: Communication & Collaboration (Telephone Services).