Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska
Emergency RFC #5298 - Outage at Jorgenson hall
Incident Report for IT
Resolved
This incident has been resolved.
Posted Mar 04, 2019 - 22:53 CST
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 04, 2019 - 22:29 CST