Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska
Firefly under investigation
Incident Report for IT
Resolved
All systems are operating normally. This issue is resolved.
Updated by Tom Anderson
Posted Jun 19, 2020 - 18:16 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 19, 2020 - 15:15 CDT
Update
We are continuing to investigate this issue.
Posted Jun 19, 2020 - 15:11 CDT
Investigating
Potential issue logging into Firefly is under investigation. Technicians are investigating the issue.
Reported by Anne Mulligan
Submitted by Tom Anderson
Questions 402-472-3970 or support@nebraska.edu
Posted Jun 19, 2020 - 15:09 CDT
This incident affected: Administrative & Business (Firefly and related applications).