Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska
Nebraska.edu Mailbox Size Rapidly Increasing under investigation
Incident Report for IT
Resolved
All systems are operating normally.
Posted Jun 01, 2022 - 13:53 CDT
Monitoring
We have completed steps to fix the subset of users who were impacted by this issue. We are continuing to monitor the situation. Please contact the Help Center if you think you are affected by this issue.
Submitted by Loren Frerichs
Posted May 20, 2022 - 16:34 CDT
Investigating
A problem with MS365 email is under investigation. Some Nebraska tenant user's mailboxes are rapidly increasing and surpassing mailbox storage quota. Technicians are investigating the issue.
Reported by Dylan Evans
Submitted by Loren Frerichs
Questions 402-472-3970 or support@nebraska.edu
Posted May 16, 2022 - 16:11 CDT
This incident affected: Communication & Collaboration (Office 365 (Email & Apps)).