Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska
Firefly on mobile devices under investigation
Incident Report for IT
Resolved
All systems are operating normally. This issue is resolved.
Posted May 17, 2019 - 10:02 CDT
Update
All issues appear to have subsided, and all systems are performing as expected. We're continuing to monitor for any reoccurring problems.
Submitted by Kevin Hopper
Posted May 16, 2019 - 13:39 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 16, 2019 - 13:38 CDT
Investigating
Potential problem with Firefly on mobile devices is under investigation. Firefly is currently experiencing issues launching Concur and other tiles on mobile devices. This does not include the installed Concur mobile App. Technicians are investigating the issue.
Reported by Shannon Poppe
Submitted by Kevin Hopper
Questions 402-472-3970 or mysupport@nebraska.edu
Posted May 16, 2019 - 11:29 CDT
This incident affected: Administrative & Business (Firefly and related applications).