Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska
Some users are experiencing long load times when accessing Canvas
Incident Report for IT
Resolved
All systems are operating normally. This issue is resolved.
Posted Mar 30, 2020 - 14:21 CDT
Monitoring
All issues appear to have subsided, and all systems are performing as expected.
Submitted by Loren Frerichs
Posted Mar 30, 2020 - 12:56 CDT
Investigating
See https://status.instructure.com/
Submitted by Loren FrerichsQuestions 402-472-3970 or support@nebraska.edu
Posted Mar 30, 2020 - 10:18 CDT
This incident affected: Teaching & Learning (Canvas).