Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska
Qualtrics at UNO under investigation
Incident Report for IT
Resolved
This incident has been resolved.
Posted Oct 19, 2020 - 14:46 CDT
Investigating
Potential problem with Qualtrics at UN is under investigation. Technicians are investigating the issue.
Reported by Rick Murch-Shafer
Submitted by Murtda Mohammed
Questions 402-472-3970 or support@nebraska.edu
Posted Oct 19, 2020 - 14:24 CDT
This incident affected: Teaching & Learning (Academic Technologies (Other)).