Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska
Student Portals (MyRed, Mavlink, MyBlue, MyRecords, Mypsc, MyCsc, Wildcats online) connection issues have resolved.
Incident Report for IT
Resolved
All systems are operating normally. This issue is resolved.
Updated by Kylie Longwell
Posted May 21, 2020 - 09:55 CDT
Investigating
Potential problem with Student Portals (MyRed, Mavlink, MyBlue, MyRecords, Mypsc, MyCsc, Wildcats online) are experiencing connection issues and is under investigation. Technicians are investigating the issue.
Reported by William Barrera Fuentes
Submitted by Kylie Longwell
Questions 402-472-3970 or support@nebraska.edu
Posted May 21, 2020 - 09:26 CDT
This incident affected: Administrative & Business (MyBlue, MyRecords, MyRed, Mavlink, MyCSC, MyPSC, WildcatsOnline).