Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska
Concur Under Investigation
Incident Report for IT
Resolved
All systems are operating normally. This issue is resolved.
Updated by Kristy Kennedy
Posted Jul 03, 2019 - 09:36 CDT
Identified
Concur is experiencing a partial outage of Expense and Travel. This is causing an inability for users to access concur. Updates will be posted as available.
Updated by Kristy Kennedy
Posted Jul 03, 2019 - 08:53 CDT
Investigating
Potential problem with Concur is under investigation. Technicians are investigating the issue.
Reported by Rene Mayo Rejai
Submitted by Kristy Kennedy
Questions 402-472-3970 or mysupport@nebraska.edu
Posted Jul 03, 2019 - 08:37 CDT
This incident affected: Administrative & Business (Firefly and related applications).