Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services. Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.
All systems are operating normally. This issue is resolved.
Posted Nov 10, 2025 - 08:45 CST
Identified
Instructure, the company who owns the Canvas learning management system, reported at 10:23AM central time that "Some users may be experiencing slow load times or timeout errors when accessing Canvas". They posted an update at 10:58AM indicating, "A fix has been implemented and we are monitoring the results." Additional information can be found on their Statuspage incident at https://status.instructure.com/incidents/sg6jnckysx5w
ITS has observed intermittent errors on University of Nebraska instances of Canvas, primarily in the admin portal but also with Speedgrader, which is used by instructors. Please check back for further updates.
Posted Nov 07, 2025 - 11:48 CST
Investigating
A problem with Canvas is under investigation. Technicians are investigating the issue.