Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska
Google Drive and Associated Applications
Incident Report for IT
Resolved
The Google Drive issue is now resolved based on Googles Status Dashboard.
Updated by Kylie Longwell
Posted Apr 12, 2021 - 12:20 CDT
Identified
Google Drive and associated applications(Google Drive, Docs, Sheets and Slides) currently have a disruption according to Google's Status Dashboard. Users are seeing error messages, high latency, and/or other unexpected behavior. Affected user are unable to create new documents. For more information about this please review Google's Status Dashboard : https://www.google.com/appsstatus#hl=en&v=status
Reported by Anna Berg
Updated by Kylie Longwell
Posted Apr 12, 2021 - 09:28 CDT
This incident affected: *Third-Party Statuses (Web Display only) (Google Apps Classroom).