Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska
DocuSign under investigation
Incident Report for IT
Resolved
All systems are operating normally. This issue is resolved.
Posted May 24, 2022 - 18:44 CDT
Update
The DocuSign service is experiencing a service disruption as of 1:49 CDT pm . The issue is being investigated by DocuSign. We will be posting additional information on our status page as we become aware of changes. also see (NA2) https://status.docusign.com/
Posted May 24, 2022 - 14:50 CDT
Investigating
Potential problem with DocuSign is under investigation. Technicians are investigating the issue.
Reported by Todd Jensen
Submitted by Loren Frerichs
Questions 402-472-3970 or support@nebraska.edu
Posted May 24, 2022 - 14:36 CDT
This incident affected: Administrative & Business (Business Applications (other)).