Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska
NeSIS Production Slowdown issues under investigation
Incident Report for IT
Resolved
All systems are operating normally. This issue is resolved.
Updated by Kristy Kennedy
Posted Jun 22, 2020 - 15:26 CDT
Monitoring
All issues have been identified, a fix implemented and verified with the customer. We're continuing to monitor for any reoccurring problems.
Submitted by Kevin Hopper
Posted Jun 22, 2020 - 11:54 CDT
Investigating
Potential problem with NeSIS Production Slowdown issues is under investigation impacting University systems only and the UNL mobile app.. Technicians are investigating the issue.
Reported by Rene Mayo-Rejai
Submitted by Kevin Hopper
Questions 402-472-3970 or support@nebraska.edu
Posted Jun 22, 2020 - 10:53 CDT
This incident affected: Administrative & Business (NeSIS (PeopleSoft)).