Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska
Concur
Incident Report for IT
Resolved
This incident has been resolved.
Posted Apr 12, 2019 - 15:18 CDT
Update
The Estimated time available is now 3pm
Posted Apr 12, 2019 - 13:14 CDT
Identified
Concur is currently unavailable due to an unexpected issue within our system. We anticipate access to Concur will be restored by 1:00 p.m. today. Please refrain from using the Concur mobile app during this time
Updated by Kevin Hopper
Posted Apr 12, 2019 - 10:37 CDT
This incident affected: Administrative & Business (Business Applications (other)).