Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska
ENREC - Eastern NE Research & Extension Center Phones Under Investigation
Incident Report for IT
Resolved
All systems are operating normally. All incoming lines are now working and outside callers are now able to contact ENREC. This issue is resolved.
Updated by Kristy Kennedy
Posted Oct 19, 2020 - 12:26 CDT
Investigating
Potential problem with ENREC - Eastern NE Research & Extension Center Phones is under investigation. All incoming lines have a fast busy tone. Technicians are investigating the issue.
Reported by Mark Christensen
Submitted by Kristy Kennedy
Questions 402-472-3970 or support@nebraska.edu
Posted Oct 19, 2020 - 11:54 CDT
This incident affected: Communication & Collaboration (Telephone Services).