Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: nusupport@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska

Poppulo digital sign Library access errors

Incident Report for IT

Resolved

Full functionality of the Library module in Poppulo Signage Cloud has been restored. All content, playlists, and Ready to Use apps are working as expected.
Posted Aug 22, 2025 - 09:00 CDT

Monitoring

A fix for the primary issue, non-admin users encountering 403 errors while utilizing Cloud, has been implemented. Poppulo recommends clearing your browser cache and restarting your browser if you are still seeing 403 access denied error messages.

An additional issue affecting Ready to Use apps and content is still being investigated. The apps and content may not be available for editing at this time.

All current content continues to play on sign players. Users should be able to manage Library content and playlist content (aside from Ready to Use apps/content) at this time. We will continue to monitor Poppulo's progress on restoring full Library functionality.
Posted Aug 21, 2025 - 14:26 CDT

Identified

Poppulo has identified the issue and their team is implementing a resolution. That work is expected to be completed soon.
Posted Aug 21, 2025 - 12:47 CDT

Update

Poppulo has updated their status page with the following message:

We are becoming aware of an issue affecting some users of the FWICloud Library.
Non-Admin users may receive 403 Forbidden errors when interacting with Library items such as playlists.
Our Dev teams are investigating the issue now. An update will be provided in 30 minutes.
Posted Aug 21, 2025 - 11:38 CDT

Investigating

Multiple users have reported receiving Error 403 Access Denied errors while trying to upload content or manage playlist items within the Poppulo Signage Cloud's Library module. The issue has been reported to Poppulo and we are awaiting their response.

All digital signs are continuing to play their existing content at this time. You just may not be able to add or change content at this time.
Posted Aug 21, 2025 - 10:12 CDT
This incident affected: Communication & Collaboration (Digital Signage).