Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska
MS365 Shared Mailbox Access Under Investigation
Incident Report for IT
Resolved
All systems are operating normally. This issue is resolved.
Updated by Bryan Fitzgerald
Posted Apr 23, 2024 - 11:03 CDT
Monitoring
The vendor has let us know that all issues appear to have subsided, and all systems are performing as expected. We're continuing to monitor for any reoccurring problems.
Submitted by Brandon Young
Posted Apr 18, 2024 - 15:24 CDT
Identified
The vendor has identified the cause of the issues and is taking steps to remediate impact to affected services. As a workaround some users affected by this issue may be able to open the affected shared mailboxes in the Outlook desktop client and mobile app.
Updated by Brandon Young
Posted Apr 17, 2024 - 07:57 CDT
Investigating
A problem with Microsoft 365 shared mailboxes is under investigation. Microsoft has informed us of a potential issue with users accessing shared mailboxes via outlook on the web and they are working on a solution. Users may see a 500 error of repeating redirects when trying to login to a shared mailbox.
Reported by Brandon Young
Submitted by Brandon Young
Questions 402-472-3970 or support@nebraska.edu
Posted Apr 15, 2024 - 15:17 CDT
This incident affected: Communication & Collaboration (Office 365 (Email & Apps)).