Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services. Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.
All systems are operating normally. This issue is resolved.
Posted Apr 28, 2026 - 09:04 CDT
Monitoring
All issues appear to have subsided, and all systems are performing as expected. We're continuing to monitor for any reoccurring problems.
Posted Apr 27, 2026 - 16:14 CDT
Identified
PowerSchool, maker of PeopleAdmin, has confirmed an issue with the application and is working to resolve it. Details are available on their Statuspage incident at https://status.powerschool.com/incidents/fgsp40z4wwb6
Posted Apr 27, 2026 - 12:15 CDT
Investigating
A problem with UNO PeopleAdmin is under investigation. UNO employees may see "Message Security Error" when logging in to PeopleAdmin. ITS is working with UNO Human Resources and their vendor to investigate the issue.