Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska
MS365 under investigation
Incident Report for IT
Resolved
All systems are operating normally. This issue is resolved.
Updated by Brandon Young
Posted Mar 09, 2023 - 10:41 CST
Investigating
Potential problem with Microsoft 365 is under investigation. Technicians are investigating the issue. Users may experience issues when looking to open apps via office online. If you experience this issues please wait 10 minutes and try refreshing your browser or by using a private or incognito browsing window.
Reported by Bryan Fitzgerald
Submitted by Brandon Young
Questions 402-472-3970 or support@nebraska.edu
Posted Mar 08, 2023 - 13:36 CST
This incident affected: Communication & Collaboration (Office 365 (Email & Apps)).