Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska
MS365 service issues
Incident Report for IT
Resolved
Microsoft confirmed that the impacted services have recovered and remain stable.
Posted Jan 25, 2023 - 08:46 CST
Identified
Users may be unable to access multiple Microsoft 365 services. Microsoft has identified the cause of the issues and is taking steps to remediate impact to affected services.

Updated by Bryan Fitzgerald
Posted Jan 25, 2023 - 08:17 CST
This incident affected: Communication & Collaboration (Office 365 (Email & Apps)).