Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services. Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.
The link has remained stable. Please report any issues or concerns to 402-472-3970 or support@nebraska.edu.
Posted Jun 03, 2026 - 13:02 CDT
Monitoring
The connection has been repaired and traffic has automatically restored to previous levels. NU Engineering will continue to monitor this.
Posted Jun 02, 2026 - 11:40 CDT
Investigating
A single connection between PKI in Omaha and the City campus in Lincoln went down at 10:16am CT; all traffic automatically re-routed through redundant connections. NU Engineering will be investigating on site soon. Questions 402-472-3970 or support@nebraska.edu
Posted Jun 02, 2026 - 10:44 CDT
This incident affected: Infrastructure (Network Backbone).