Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska
Canvas under investigation
Incident Report for IT
Resolved
All systems are operating normally. This issue is resolved.
Posted Sep 22, 2022 - 08:31 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 21, 2022 - 13:38 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 21, 2022 - 13:32 CDT
Update
To view the most recent updates from Canvas, please visit https://status.instructure.com/incidents/gnpq11b6p51f
Posted Sep 21, 2022 - 13:27 CDT
Investigating
Large Portion of Canvas Clients are experiencing Slow load times and errors in the US Region
Questions 402-472-3970 or support@nebraska.edu
Posted Sep 21, 2022 - 13:20 CDT
This incident affected: Teaching & Learning (Canvas).