Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska
TurnItIn under investigation
Incident Report for IT
Resolved
All systems are operating normally. This issue is resolved.
Posted Oct 28, 2024 - 16:56 CDT
Monitoring
All issues appear to have subsided, and all systems are performing as expected. We're continuing to monitor for any reoccurring problems.
Posted Oct 28, 2024 - 14:25 CDT
Update
The vendor is actively investigating this issue. Updates are available on their Statuspage incident at https://turnitin.statuspage.io/incidents/2xhyzn6b3hmc
Posted Oct 28, 2024 - 13:14 CDT
Investigating
A problem with TurnItIn is under investigation. TurnItIn is currently not responding within Canvas and users are seeing 503 errors displayed. This is affecting TurnItIn/Canvas at UNO, UNL, and UNK. NU ITS technicians are currently working with the vendor on the issue.

Questions 402-472-3970 or support@nebraska.edu
Posted Oct 28, 2024 - 11:11 CDT
This incident affected: Teaching & Learning (Canvas).