Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska
Phone Service in Seaton, Benton, Fairfield Halls Under Investigation
Incident Report for IT
Resolved
This incident has been resolved.
Posted Feb 25, 2020 - 10:48 CST
Update
Windstream is continuing to work on this issue.
Posted Feb 24, 2020 - 16:43 CST
Update
Windstream is continuing to work on this issue, expected resolution should be Friday end of the business day.
Posted Feb 19, 2020 - 13:04 CST
Identified
Windstream has identified the cause of the issues and is taking steps to remediate impact to affected services.
Updated by Paula Lampe
Posted Feb 18, 2020 - 17:01 CST
Investigating
Potential problem with some lines of phone service in Seaton Hall, Benton Hall and Fairfield Hall. Windstream techinicians are working on a trunking cable and are aware of the issue.
Reported by Paula Lampe
Submitted by William Jones
Questions 402-472-3970 or support@nebraska.edu
Posted Feb 18, 2020 - 10:51 CST
This incident affected: Communication & Collaboration (Telephone Services).