Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services. Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.
During scheduled maintenance on a low-level component of the Jamf Pro cloud infrastructure, an update failed, resulting in an outage that affected Jamf Pro customers. The component in question is a critical part of our auto-scaling infrastructure, which enables Jamf to support millions of devices. The failure of this upgrade led to a widespread outage.
The update was not backwards-compatible, making it impossible to roll back to the previous version.
We were able to quickly restore services for some configurations, including Premium Cloud customers.
Larger clusters could not be recovered through the standard workflow and required manual intervention. We had to downsize these clusters to enable recovery.
For customers with custom domains, an additional step was needed before service could be fully restored.
Posted Apr 18, 2025 - 14:40 CDT
Resolved
All systems are operating normally. This issue is resolved.
Posted Apr 16, 2025 - 15:51 CDT
Monitoring
All issues appear to have subsided, and all systems are performing as expected. We're continuing to monitor for any reoccurring problems.
Posted Apr 16, 2025 - 07:53 CDT
Identified
The vendor has confirmed an issue with this hosted service that is affecting multiple customers. Details are available on their Statuspage incident page at https://status.jamf.com/incidents/1hxkjgbwqknq We will provide further updates as we receive additional information.
Posted Apr 15, 2025 - 16:02 CDT
Investigating
A problem with Jamf is under investigation. The Self Service application on Mac and iOS devices is currently unavailable, as is the Jamf Pro Server environment used by IT staff to manage these endpoints. Technicians are investigating the issue.