Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services. Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.
All issues appear to have subsided, and all systems are performing as expected. We're continuing to monitor for any reoccurring problems.
Posted Apr 06, 2026 - 14:04 CDT
Update
NU campus portals for the student information system (MyBlue, MyRed, MyNCTA, MyRecords, and MavLink) remain unavailable. At this time, users will not be able to perform actions including: register for courses, visit course schedule websites, request transcripts, apply for admission, make payments, manage or allocate hours to employee/dependent scholarships, or other related services that integrate with the student information system. Additional updates will be posted as more information becomes available.
Posted Apr 06, 2026 - 12:59 CDT
Update
We are continuing to investigate this issue. In addition to campus portals, other sites and applications which rely on integrations with PeopleSoft (the student information system) may also be affected. Other known impacts include course schedule websites, tuition payment, employee/dependent scholarship functionality in Firefly, and more.
Posted Apr 06, 2026 - 11:45 CDT
Update
We are continuing to investigate this issue.
Posted Apr 06, 2026 - 11:04 CDT
Investigating
A problem with the PeopleSoft Student Information System portals - MyBLUE, MyRED, MavLINK, MyRecords, and MyNCTA - is under investigation. Admissions applications may also be impacted. Technicians are investigating the issue.