Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services. Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.
All systems are operating normally. This issue is resolved.
Posted Feb 15, 2024 - 13:55 CST
Monitoring
All issues appear to have subsided, and all systems are performing as expected. We're continuing to monitor for any reoccurring problems. Submitted by Loren Frerichs
Posted Feb 14, 2024 - 11:37 CST
Investigating
A problem with Online Bill Pay is under investigation. You may not receive an email when paying your cellular bill with ITS Telecom. Technicians are investigating the issue. Reported by Todd Jensen Submitted by Loren Frerichs Questions 402-472-3970 or support@nebraska.edu
Posted Feb 14, 2024 - 09:30 CST
This incident affected: Administrative & Business (Business Applications (other)).