Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska
Redundant backbone link to the Bellevue Data Center down
Incident Report for IT
Resolved
The vendor has identified and resolved the issue, all systems are operating normally.
Posted May 13, 2024 - 16:10 CDT
Investigating
A vendor is performing emergency maintenance that will impact one of the links to the Bellevue Data Center. This is unrelated to the backbone issue from earlier today.
Questions 402-472-3970 or support@nebraska.edu
Posted May 13, 2024 - 16:03 CDT
This incident affected: Infrastructure (Network Backbone).