Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services. Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 16, 2026 - 09:00 CDT
Scheduled
RFC 203354: UPS and PDUs will undergo maintenance. Direct impact: No impact to users or services at NPM is expected to occur. There is a Meraki switch with only one power supply that will lose power when it is being moved to the new UPS but the building IT staff informed us the switch is only needed during events and won't cause any issues when it loses power during our maintenance window. ITS will be replacing UPS and PDU equipment in Nebraska Public Media CER Cabinets during this time. Entered by - Casey Wallace Questions 402-472-3970 or support@nebraska.edu
Posted Mar 13, 2026 - 14:15 CDT
This scheduled maintenance affected: Infrastructure (Network Backbone).