Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska

Telecom Web Site issue identified

Incident Report for IT

Resolved

Maintenance has been performed on the phone servers that has resolved this issue.
Posted Apr 22, 2025 - 21:59 CDT

Identified

A problem with Telecom websites https://phone.unk.edu https://phone.unl.edu https://phone.unomha.edu has been identified. Chrome Web Browser is not working for these sites, a work around is using other web browsers like Microsoft Edge or Safari. Telecom is currently working with our vendor to resolve this problem.
Reported by Mike Hansen
Submitted by Loren Frerichs
Questions 402-472-3970 or support@nebraska.edu
Posted Apr 18, 2025 - 09:06 CDT
This incident affected: Communication & Collaboration (Telephone Services).