Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services. Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.
All systems are operating normally. This issue is resolved.
Posted Nov 21, 2025 - 09:09 CST
Monitoring
All issues appear to have subsided, and all systems are performing as expected. We're continuing to monitor for any reoccurring problems.
Wepa provided the following update: "We experienced a widespread outage due to unexpected issues with an overnight kiosk application update. Our developmental team has been made aware of the issue and pushed out another update this morning to resolve the issue. Our affected kiosk numbers are in the single digits now. If you are still having issues or have any questions or concerns, please let us know and we'll be happy to assist."
Posted Nov 21, 2025 - 08:37 CST
Identified
At this time, only a small number of printing kiosks in Kearney and Lincoln are inoperable.
Wēpa provided the following information: "We are experiencing widespread outages due to unexpected issues with a kiosk application update that went out yesterday/overnight. Our higher level developmental team members have already been notified and are currently working to resolve the issue."
We will post additional updates as more information becomes available.
Posted Nov 21, 2025 - 08:33 CST
Investigating
A problem with Wepa printer kiosks is under investigation. Technicians are investigating the issue.