Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska
NeSIS - PeopleSoft System down time including Mavlink, MyBlue, MyCSC, MyNCTA, MyPSC, MyRecords, MyRED and WildcatsOnline
Scheduled for Oct 2, 20:00 CDT  -  Oct 3, 05:00 CDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Sep 23, 2022 - 16:18 CDT
Scheduled
RFC-11322: NeSIS - PeopleSoft System will unavailable during maintenance. ITS will be preforming quarterly maintenance to the PeopleSoft System including Mavlink, MyBlue, MyCSC, MyNCTA, MyPSC, MyRecords, MyRED and WildcatsOnline during this time.
Entered by - Loren Frerichs Questions 402-472-3970 or support@nebraska.edu
Posted Sep 16, 2022 - 14:44 CDT
This scheduled maintenance affects: Information Security (Authorization) and Administrative & Business (MyBlue, MyRecords, MyRed, Mavlink, MyCSC, MyNCTA, MyPSC, NeSIS (PeopleSoft), WildcatsOnline).