Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services. Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.
We've confirmed that our networking change reversion has completed, and our telemetry indicates that our service has recovered following this action. We're closely monitoring our telemetry and reaching out to sample affected users to validate resolution while we evaluate what other actions may be needed.
Posted Jul 23, 2026 - 14:14 CDT
Identified
Users may experience issues accessing or using Microsoft 365 services routed through the North America region.
More info:
We've confirmed that the issue may affect multiple Microsoft 365 services, including but not limited to: - Microsoft OneDrive: Intermittent connection issues. - SharePoint Online: Intermittent connection issues. Some users are receiving “Something went wrong” errors. - Microsoft Teams: Degraded chat functionality, including images not loading. Additionally, real-time voice apps reporting and historical reporting are not functioning as expected. - Copilot Chat: Intermittent delays using Copilot Chat and failures in query actions. - Microsoft 365 Admin Center: Latency and intermittent inability to access features - Power Automate: Automate flows not loading. - Microsoft Loop: Unable to open or load Loop pages. - Microsoft Purview: Degraded Purview DLP Agent response time. eDiscovery and Data Security Investigations failures when submitting new jobs and delays in processing existing jobs. - Fabric/Power BI: Users in the West US region may encounter issues accessing Publish to Web reports. Some users in Europe and Asia Pacific regions may also be intermittently delayed when accessing Fabric artifacts due to service dependencies in West US.
-Power Apps
Users may experience some issues accessing the Power Apps Portal and may also experience Canvas Apps not loading and data sources failing to connect.
-Copilot Studio
Users may be unable to load the Copilot Studio Portal and data sources may also fail to connect. -Windows 365: Users may be unable to select a non-English (United States) language for their Cloud PC post provisioning. They can try reprovisioning and language selection again and it may succeed on retry.
Posted Jul 23, 2026 - 14:13 CDT
This incident affects: Communication & Collaboration (Microsoft 365 - Outlook (Exchange Online), Microsoft 365 - Teams (Collaboration & Storage), Microsoft 365 - Sharepoint / OneDrive (Storage), Microsoft 365 - Other Apps (PowerApps, Office, etc...)).