Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services. Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.
All login issues to the Microsoft 365 services appear to have subsided, and all systems are performing as expected. We're continuing to monitor for any reoccurring problems. Submitted by Brandon Young
Posted Feb 23, 2026 - 10:29 CST
Investigating
A problem with Microsoft 365 login is under investigation. The issue has been reported to the vendor. Reported by Megan Haugerud Submitted by Brandon Young Questions 402-472-3970 or support@nebraska.edu
Posted Feb 23, 2026 - 09:23 CST
This incident affects: Communication & Collaboration (Microsoft 365 - Outlook (Exchange Online), Microsoft 365 - Teams (Collaboration & Storage), Microsoft 365 - Sharepoint / OneDrive (Storage), Microsoft 365 - Other Apps (PowerApps, Office, etc...)).