Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services. Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.
All systems are operating normally. This issue is resolved. Updated by Loren Frerichs
Posted Oct 02, 2020 - 08:38 CDT
Monitoring
All issues appear to have subsided, and all systems are performing as expected. We're continuing to monitor for any reoccurring problems. Submitted by Mark Woitaszewski per Brandon Young
Posted Sep 29, 2020 - 06:30 CDT
Investigating
Problem with multiple Microsoft 365 services is under investigation. Our vendor is investigating the issue. Reported by Matthew Ware Submitted by Loren Frerichs Questions 402-472-3970 or support@nebraska.edu
Posted Sep 28, 2020 - 17:06 CDT
This incident affected: Communication & Collaboration (Microsoft 365 - Outlook (Exchange Online)).