Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services. Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.
A fix has been implemented and we are monitoring the results.
Posted Aug 24, 2026 - 16:04 CDT
Update
The vendor is continuing efforts to restore traffic within the impacted environment.
As a temporary workaround, please access your Office applications via the web at portal.office.com. Updated by Bryan Fitzgerald
Posted Aug 24, 2026 - 14:30 CDT
Identified
The vendor has posted a service degradation for trying to active new or refresh existing Office 365 applications. The vendor is actively working to resolve this issue however there is currently no timetable. Updated by Bryan Fitzgerald
Posted Aug 24, 2026 - 11:19 CDT
This incident affected: Communication & Collaboration (Microsoft 365 - Other Apps (PowerApps, Office, etc...)).