Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services. Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.
Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted May 25, 2025 - 10:09 CDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 23, 2025 - 18:00 CDT
Scheduled
RFC 120134: MS365 Huskers.com tenant, including email, will be unavailable during maintenance. Direct impact: Huskers.com MS365 applications will be unavailable during maintenance. Email delivery will be held during maintenance. ITS will be migrating the Huskers.com tenant and domain names during this time. Entered by - Eric Haffey Questions 402-472-3970 or support@nebraska.edu
Posted May 21, 2025 - 14:44 CDT
This scheduled maintenance affected: Communication & Collaboration (Microsoft 365 - Outlook (Exchange Online), Microsoft 365 - Teams (Communication & Voice), Microsoft 365 - Teams (Collaboration & Storage), Microsoft 365 - Sharepoint / OneDrive (Storage), Microsoft 365 - Other Apps (PowerApps, Office, etc...), Microsoft 365 / ProofPoint - Email Deliverability & Processing).