Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska
WebCheckout under investigation
Incident Report for IT
Resolved
All systems are operating normally. This issue is resolved.
Posted Nov 11, 2022 - 13:34 CST
Monitoring
All issues appear to have subsided, and all systems are performing as expected. We're continuing to monitor for any reoccurring problems.
Posted Nov 10, 2022 - 16:42 CST
Update
We are continuing to investigate this issue.
Posted Nov 10, 2022 - 16:41 CST
Investigating
Potential problem with WebCheckout is under investigation. Technicians are investigating the issue.
Reported by Rich Horner
Submitted by Loren Frerichs
Questions 402-472-3970 or support@nebraska.edu
Posted Nov 10, 2022 - 16:29 CST
This incident affected: Administrative & Business (Business Applications (other)).