Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: nusupport@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska

MS365 omavs.com/baxterarena.com email downtime

Incident Report for IT

Resolved

All systems are operating normally. Work has been completed.
Posted Jul 28, 2025 - 08:48 CDT

Monitoring

Migrations have completed and we continue to verify all email is routing successfully. If you have any issues please contact nusupport@nebraska.edu.
Submitted by Bryan Fitzgerald
Posted Jul 21, 2025 - 08:14 CDT

Update

Maintenance continuing as anticipated. Expected completion is Monday morning.
Posted Jul 20, 2025 - 11:30 CDT

Identified

RFC 131236: MS365 for omavs.com/baxterarena.com, including email, will be unavailable during maintenance.  Direct impact: omavs.com/baxterarena.com MS365 applications will be unavailable during maintenance.  Email delivery will be held during maintenance.  ITS will be migrating the omavs.com/baxterarena.com email and domain names during this time.
Entered by - Bryan Fitzgerald Questions 402-472-3970 or support@nebraska.edu
Posted Jul 18, 2025 - 13:46 CDT
This incident affected: Communication & Collaboration (Microsoft 365 - Outlook (Exchange Online), Microsoft 365 - Teams (Communication & Voice), Microsoft 365 - Teams (Collaboration & Storage), Microsoft 365 - Sharepoint / OneDrive (Storage), Microsoft 365 - Other Apps (PowerApps, Office, etc...), Microsoft 365 / ProofPoint - Email Deliverability & Processing).