Welcome to the ITS status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska
Hotel Booking Application within Concur issue has been identified
Incident Report for IT
Resolved
All systems are operating normally. This issue is resolved.
Updated by Kylie Longwell
Posted Jan 06, 2021 - 09:02 CST
Identified
There is an issue with the hotel booking application within Concur: the system is not asking for a cost center number. This is a known issue and Fox World Travel is currently working toward a resolution. ITS has identified the cause of the issues and is taking steps to remediate impact to affected services.
Updated by Kylie Longwell
Posted Jan 05, 2021 - 10:58 CST
This incident affected: Administrative | Business (Firefly and related applications).