Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at its.nebraska.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: nusupport@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska

LES Power outage for UNL City Campus

Scheduled for Jul 14, 00:00 - 05:00 CDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Jul 06, 2026 - 14:54 CDT

Scheduled

RFC 233551: The primary LES feed to the UNL City Campus will undergo maintenance. Direct impact: LES will be moving the primary electrical feed from overhead to underground. No electrical power to the buildings. All systems will be affected unless specifically on emergency backup power. Please save any open computer files, perform backups as required, safely shut down sensitive electronic equipment, and be prepared for a temporary loss of area lighting, HVAC systems, and other electrical/electronic systems.

Buildings Impacted:
501 Building
Alexander Building
Andrews Hall
Architecture Hall
Behlen Laboratory
Benton Hall
Bessey Hall
Brace Laboratory
Burnett Hall
Canfield Administration North
Canfield Administration South
Caryolyn Pope Edwards Hall
Cornhuskers Athletic Complex (MSTD)
Fairfield Hall
Henzlik Hall
Jackie Gaughan Multicultural Center
Kauffman Academic Residential Center
Kimball Recital Hall
Louise Pound Hall
Love Library North
Love Library South
Manter Hall
Memorial Stadium North
Meuller Tower
Morrill Hall
Nebraska Union
Oldfather Hall
Outdoor Adventure Center
Pershing Military & Naval Science Building
Richards Hall
Schorr Center
Seaton Hall
Selleck Quadrangle
Sheldon Museum of Art
Stadium Drive Parking Garage
State Historical Society
Teachers College Hall
University Health Center (OLD)
Westbrook Music Building
Wick Alumni Center
Woods Art Building Questions 402-472-3970 or support@nebraska.edu
Posted Jul 06, 2026 - 14:44 CDT
This scheduled maintenance affects: Infrastructure (LINCOLN - City Campus Wired Network Connections, LINCOLN - City Campus Wireless Network Connections).