Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services. Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.
Due to a technical concern, TDX has decided to roll back the new version of the service for the US-based customers who received it this weekend. Systems are now operating as expected.
Posted Jun 02, 2025 - 15:05 CDT
Monitoring
TeamDynamix has marked this issue Monitoring. The new GUI has been rolled back for institutions that received it this weekend.
Posted Jun 02, 2025 - 12:49 CDT
Update
At this time, only the technician interface for TDX appears to be affected. This is primarily used by IT staff.
The Client Portal, used by faculty, staff, students, and other end users, is still available and working as expected. Users will likely experience delays when submitting tickets, as IT staff are currently unable to access them.
Posted Jun 02, 2025 - 08:01 CDT
Identified
ITS has identified the cause of the issues. Our ITSM vendor, TeamDynamix (TDX), has posted an issue on their Statuspage indicating, "We are actively investigating reports of performance degradation this morning. This seems to mostly affect the Work Management (Users: formerly TDNext) interface at this time." This appears to be affecting all TDX customers, not just the University of Nebraska.
Posted Jun 02, 2025 - 07:51 CDT
Investigating
A problem with TeamDynamix is under investigation. Technicians are investigating the issue. Reported by Adam Broich Submitted by Loren Frerichs Questions 402-472-3970 or support@nebraska.edu
Posted Jun 02, 2025 - 07:41 CDT
This incident affected: Administrative & Business (Business Applications (other)).