Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska

Microsoft 365 - Email

Incident Report for IT

Resolved

All systems are operating normally. This issue is resolved.
Posted Mar 01, 2025 - 19:24 CST

Monitoring

Microsoft has reverted a code change and is currently monitoring the service to ensure it has returned to a healthy state.
Posted Mar 01, 2025 - 17:26 CST

Identified

Microsoft is currently experiencing a worldwide outage impacting email services.

Questions 402-472-3970 or support@nebraska.edu
Posted Mar 01, 2025 - 15:30 CST
This incident affected: Communication & Collaboration (Microsoft 365 / ProofPoint - Email Deliverability & Processing).