Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska
Greater Nebraska Wireless Download Speeds
Incident Report for IT
Resolved
All systems are operating normally. This issue is resolved (by RFC-10991).
Updated by Loren Frerichs
Posted Jul 11, 2022 - 11:35 CDT
Update
We continue to work with our vendors to resolve this issue.
Posted Jul 08, 2022 - 11:51 CDT
Update
PRB-1353 We are continuing to investigate this issue.
Posted Jun 22, 2022 - 14:25 CDT
Update
We are continuing to investigate this issue.
Posted Jun 13, 2022 - 17:25 CDT
Investigating
Some Greater Nebraska locations are experiencing limited download speeds over wireless connections. Upload speeds and the wired network have not been impacted. ITS with our service and hardware vendors are working on returning normal network symmetrical speeds to the impacted locations.
Posted Jun 13, 2022 - 17:24 CDT
This incident affected: Infrastructure (Research Center & Extension Connections).