Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services. Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.
All systems are operating normally. This issue is resolved.
Posted May 05, 2026 - 09:54 CDT
Monitoring
At 5:09PM central time, Turnitin reported, "We are pleased to advise that service has been restored."
Between 5:30PM on Friday, May 1st, 2026 and 4:10PM on Monday, May 4th, 2026, "users might have been unable to access or generate similarity reports via Canvas LMS submitted via Canvas Plagiarism Framework (CPF)." Canvas will resubmit the affected submissions, though this may take a while to complete.
NU ITS is continuing to monitor for any reoccurring problems.
Posted May 04, 2026 - 18:58 CDT
Investigating
Turnitin has reported that due to an unplanned key rotation by Instructure (Canvas), "users will encounter issues accessing reports via Canvas LMS submitted via Canvas Plagiarism Framework (CPF)." Details are available on the Turnitin Statuspage site at https://turnitin.statuspage.io/incidents/6hhjq0w36mvf
The University of Nebraska has not yet observed any impacts to faculty, staff, or students but are monitoring for issues to our environment.