Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services. Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.
All systems are operating normally. This issue is resolved.
Posted Mar 29, 2024 - 09:18 CDT
Monitoring
All issues appear to have subsided, and all systems are performing as expected. We're continuing to monitor for any reoccurring problems. Submitted by Bryan Fitzgerald
Posted Mar 28, 2024 - 13:46 CDT
Identified
ITS has identified the cause of the issues and is taking steps to remediate impact to affected services. UNK is the only campus that is impacted by this incident. Updated by Bryan Fitzgerald
Posted Mar 26, 2024 - 13:27 CDT
This incident affected: Communication & Collaboration (Microsoft 365 - Outlook (Exchange Online)).