Welcome to the ITS status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska
Telephone - Eastern Nebraska Research and Extension Center under investigation
Incident Report for IT
Resolved
All systems are operating normally. This issue is resolved.
Updated by Loren Frerichs
Posted Nov 13, 2020 - 08:22 CST
Identified
Our vender continues to work on the issue.
Updated by Loren Frerichs
Posted Nov 12, 2020 - 16:42 CST
Investigating
A problem with telephone service at Eastern Nebraska Research and Extension Center is under investigation. Technicians are investigating the issue.
Reported by Mark Christensen
Submitted by Loren Frerichs
Questions 402-472-3970 or support@nebraska.edu
Posted Nov 11, 2020 - 16:54 CST
This incident affected: Communication and Collaboration (Telephone Services).