Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services. Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 02, 2026 - 08:00 CDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Apr 30, 2026 - 09:56 CDT
Scheduled
RFC 218353: Grand Island backbone circuits will be affected while we reboot a device. Short network disruption may be possible while the network reconverges on a redundant path.
TierPoint backbone circuit will be affected while we reboot a device. Short network disruption may be possible while the network reconverges on a redundant path. Questions 402-472-3970 or support@nebraska.edu
Posted Apr 30, 2026 - 09:53 CDT
This scheduled maintenance affected: Infrastructure (Network Backbone).