Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska

Digital Signage - Poppulo/FWI Cloud portal outage

Incident Report for IT

Resolved

This incident has been resolved.
Posted Mar 21, 2025 - 15:11 CDT

Monitoring

Poppulo Signage Cloud site performance has returned to normal operations. We are monitoring for recurring issues but expect to categorize this as resolved by the end of the business day today.
Posted Mar 21, 2025 - 13:05 CDT

Identified

Poppulo has identified that a routine software release had a negative impact on the site's responsiveness. The release concluded yesterday and site performance is being tested.
Posted Mar 21, 2025 - 09:41 CDT

Investigating

The portal for managing digital sign content and schedules (Poppulo Signage Cloud aka FWI Cloud) is experiencing intermittent outages. Some users are seeing a blank page when trying to login at fwicloud.com. Others are able to login but then further pages refuse to load. A ticket has been submitted to Poppulo and several requests for updates have been made, with no response yet.
Posted Mar 20, 2025 - 12:32 CDT
This incident affected: Communication & Collaboration (Digital Signage).